Cheetah Digital is experiencing an issue.

Incident

Cheetah Digital is experiencing an issue.

Status: closed
Start:
End:
Duration: 4 hours 35 minutes
Affected Components:
EMEA Region API Services FTP
Investigating

Cheetah Digital is experiencing a technical issue affecting one of our domains. As a result, API requests, FTP access, and some reporting functionality may be impacted for EMEA customers. Our teams are actively investigating and will work diligently to find a solution. 


Clients may experience impacts including:

We will continue to post updates and resolution information here. If you need additional support, please contact Cheetah Support or your account manager.

Identified

The technical team has identified the underlying issue and is working to restore normal service as quickly as possible.


Clients may experience impacts including:

We will continue to post updates and resolution information here. If you need additional support, please contact Cheetah Support or your account manager.

Identified

The team continues to work on resolving the issue and is coordinating the remaining steps required to restore service. We will provide another update as soon as new information is available.

Resolved

Earlier we identified a technical issue affecting one of our EMEA domains.Our teams have resolved the issue and the platform and campaign operations are now operating as expected. 


If you experience any lingering concerns, please contact Support or your account manager.